Word-to-LaTeX Manual

This manual replaces the former PDF manual. Not all parts of the old manual have already been transformed here. If you cannot find anything, please try the PDF manual or do not hesitate to ask at .

Table of Contents

1. Introduction

1.1 Features

Word-to-LaTeX converts allows for converting all parts of Word documents including footnotes, font styles, equations, images, etc. The full list of features follows.

Input formats

Output formats

User interface

Images

Headings

Equations

Lists

Tables

Font styles

Special characters

Footnotes, Endnotes

Styles

References

Colors

Alignment, Indentation

Various features

Sample Document

A short Word document below shows the key Word-to-LaTeX features. You can see that Word-to-LaTeX correctly transformed:

Original Word document [DOC] [PDF] Converted LaTeX document [TEX] [PDF]

Here is the complete LaTeX listings created by Word-to-LaTeX. You can download in by clicking the TEX link. You can also download the Word-to-LaTeX configuration that was used to convert this document.

Converted LaTeX file [TEX], Image 1 [EPS], Image 2 [EPS], Configuration for Word-to-LaTeX [XML]

\documentclass[12pt]{article}
\usepackage[dvips]{graphicx}
\usepackage{ulem}
\usepackage{amsmath}
\usepackage{palatino}
\usepackage[T1]{fontenc}
\author{Michal Kebrt}
\title{Word-to-LaTeX Sample Document}
\usepackage[paperwidth=595pt,paperheight=841pt,top=28pt,right=70pt,bottom=49pt,left=70pt]{geometry}
\setlength{\parskip}{10pt}
\setlength{\parindent}{0pt}
\pagestyle{empty}

\begin{document}
\section{Font Styles}

Vehicula \textit{italic }odio nec lacus fringilla \textsc{SmallCaps}
sodales est tristique. \uline{Underline} commodo
\textbf{\textit{bolditalic}} nunc, euismod \texttt{typewriter} lacinia
non. \uppercase{ALLCAPS} sit amet egestas eros m$^{2}$.

\subsection{Lists and Special Characters}

\begin{itemize}
	\item ar\^{e}te, f\"{o}rv\aa{}nad, \v{z}lut\'{y}, s\o{}ndag, k\r{u}\v{n},
s\l{}ycha\'{c}, Dzi\k{e}kuj\k{e}, ense\~{n}ar, Le\~{a}o, Dovi\dj{}enja
\begin{itemize}
	\item w\"{u}nscht, gro\ss{}e,~Bet\"{a}tigung, k\"{o}rperlicher, englez\u{a},
a\u{g}a\c{c}, ayd\i{}nl\i{}k
\end{itemize}

\end{itemize}

\subsection{Equations}

Lorem $\sqrt{a^2+b^2}$  ipsum
${\left(x+a\right)}^n=\sum_{k=0}^n\binom{n}{k}x^ka^{n-k}$ dolor sit
amet $\frac{dy}{dx}$ eli.

\[f\left(x\right)=a_0+\sum_{n=1}^{\infty{}}\left(a_n\cos{\frac{n\pi{}x}{L}}+b_n\sin{\frac{n\pi{}x}{L}}\right)\]

\section{Table}

Lorem ipsum dolor sit amet, \textbf{consectetur} adipiscing elit.

\vspace{3pt} \noindent
\begin{tabular}{|p{101pt}|p{101pt}|p{101pt}|p{101pt}|}
\hline
abcd
 & $e^{-ti\theta{}}$ & $A=\pi{}r^2$ & $\max_{0\leq{}x\leq{}1}{xe^{-x^2}}$ \\
\hline
123
 & 
456
 & 
\textbf{789}
 & 
123
 \\
\hline
\end{tabular}
\vspace{2pt}
\section{Images}

Excel graph embedded in the document (\textbf{vector} \textit{image}).

\includegraphics[width=281pt]{img-1.eps}

Donald Knuth\footnote{computer scientist and Professor Emeritus at
\textbf{Stanford} University} \textendash{} creator of  T$_{E}$X
(\textbf{raster} \textit{image}).

\includegraphics[width=56pt]{img-2.eps}
\end{document}

2. Installation

2.1 Requirements

Before proceeding with the installation, please make sure that your system meets the following requirements. Word-to-LaTeX runs on Windows operating systems and requires Mirosoft Office to be installed on the host machine. These versions are supported.

Microsoft Windows Microsoft Office
  • Windows 71
  • Windows Vista1
  • Windows XP1
  • Windows 2000
  • Windows Server 20031
  • Windows Server 20081

1 including 64-bit version

  • Office 20102
  • Office 2007
  • Office 2003
  • Office XP (2002)

2 including Office 2010 64-bit (use Word-to-LaTeX 64-bit only in this case)

When you need to convert mathematical formulas created in so called Equation Editor (which was the default editor in Microsoft Office 2003 and older) or in the MathType editor, you must have MathType installed. There is no need to have MathType installed to convert formulas created in the default mathematical editor in Microsoft Office 2007 and 2010 .

Linux and Mac

Word-to-LaTeX does not run on Linux and Mac operating systems. The only possible way of running Word-to-LaTeX on a different operating systems is to create a virtual machine inside a non-Windows operating system and then install Microstt Windows, Microsft Office, and Word-to-LaTeX inside that virtual machine. You can use Parallels, VirtualBox, or any other virtualization product to create a virtual machine.

2.2 Installing

After you have purchased a valid license and downloaded the installation package, please follow these instructions.

  1. Login as Administrator or any other user with the administrator privileges.
  2. Make sure that Microsoft Word is not running.
  3. Unpack the installation .zip archive (contains setup.exe file and one .msi file)
  4. Run setup.exe file. You may verify the origin of the file by checking that it was published by Michal Kebrt who is the person representing Word-to-LaTeX.
  5. Word-to-LaTeX requires the .NET Framework to be installed on your machine. The .NET Framework slowly becomes a standard for Windows applications. If you do not have the .NET Framework installed, you will be asked to do it which will take a few minutes. After the .NET Framework has been installed, restart Windows and continue from the step 4.
  6. Follow the instructions provided by the installation program.

Word-to-LaTeX EPS Printer

Word-to-LaTeX EPS Printer allows for exporting figures and other objects embedded in Word documents to EPS. The EPS format is a usual way of of insterting figures in LaTeX documents.

Word-to-LaTeX EPS Printer is installed together with the Word-to-LaTeX converter. In order to export figures correctly, the printer has to use A4 as a default paper size. Please follow these steps to check whether it is set up correctly.


1. Open Devices and Printers

2. Right click Word-to-LaTeX EPS Printer and select Printing Preferences

3. Click the Advanced... button

4. Select A4 Paper Size and click OK, and then click Apply

2.3 Upgrading

The upgrading process comprises of two actions. First you have to uninstall the previous Word-to-LaTeX version. Then you will follow the installation instructions.

2.4 Uninstalling

To uninstall Word-to-LaTeX from your computer go to Control Panel → Add or Remove Programs and select Word-to-LaTeX. Before uninstalling, make sure that Microsoft Word is not running.

3. Running

3.1 Microsoft Word Add-in

Security Settings

Microsoft Word has a strict policy for add-ins and templates installed by a third party software. If you have the most strict policy set, Word-to-LaTeX add-in is likely not to appear in Microsoft Word. To resolve this issue, follow these steps.

Microsoft Office 2010

  1. Run Microsoft Word
  2. Click the File tab in the upper left corner and then click Options
  3. Click Trust Center, click Trust Center Settings..., and then click Macro Settings
  4. Select Disable all macros with notification, then click OK, and then OK again
  5. Restart Microsoft Word
  6. A security warning will appear, click the Macros have been disabled link
  7. Click the Enable Content button and select Advanced Options
  8. Verify that Word-to-LaTeX.dot is signed1 by Michal Kebrt (person representing Word-to-LaTeX), and select Trust all documents from this publisher, and click OK

Microsoft Office 2007

  1. Run Microsoft Word
  2. Click the round Microsoft Office Button in the upper left corner and then click Word Options
  3. Click Trust Center, click Trust Center Settings..., and then click Macro Settings
  4. Select Disable all macros with notification, then click OK, and then OK again
  5. Restart Microsoft Word
  6. A security warning will appear, click Options...
  7. Verify that Word-to-LaTeX.dot is signed1 by Michal Kebrt (person representing Word-to-LaTeX), check Trust all documents from this publisher, and click OK

Microsoft Office XP/2003

  1. Run Microsoft Word
  2. Select Tools → Macro → Security... from the main menu
  3. Check High. Only signed... security level and click OK.
  4. Restart Microsoft Word
  5. A security warning will appear. Verify that macro is signed1 by Michal Kebrt (person representing Word-to-LaTeX).
  6. Check Always trust macros from this publisher and click Enable Macros

1 Word-to-LaTeX add-in is signed by a trusted certificate from Comodo.

Opening Word-to-LaTeX

Using the Word-to-LaTeX Word add-in is by far the most convenient. Just open the document (doc, docx, rtf) in Microsoft Word and then click the Word-to-LaTeX icon . In Word 2000-2003 you will find the icon on the command bar, in Word 2007-2010 go to the Add-Ins ribbon tab as seen on the screenshot below.

Running Word-to-LaTeX in Microsoft Word 2010

After the clicking icon, Word-to-LaTeX main window will appear and allow you to convert the active document. See the next section for instructions on how to continue with the conversion.

No Word-to-LaTeX icon

If you do not see any Word-to-LaTeX icon in Microsoft Word, please verify that Word-to-LaTeX.dot file is located in C:\Program Files\Microsoft Office\Office14\Startup (or a similar location depending on your Microsoft Office version). If is not present there, copy it from C:\Program Files\Word-to-LaTeX into that Startup folder and restart Microsoft Word.

Also please verify your security settings.

3.3 Converting Documents

After you run Word-to-LaTeX (either from Word Add-in or by clicking Word-to-LaTeX icon on your Desktop or in Start menu), the following window will appear. If you want to quickly start and do not need special customization for your document, do these steps.

  1. Select input file by clicking Browse... next to the Input file field. When you use the Word Add-in, the active document will always be preselected.
  2. Select the output file by clicking Browse... next to the Output file field. If you leave the output file empty, the input filename appended with .tex will be used.
  3. Click the Convert button
  4. You can see conversion progess in the text box below.

Conversion tab

Error occured during conversion

If a problem occurs during the conversion, you will be notified in progress text box. Please let us know to and attach the document that failed to convert. We will do our best to resolve the issue.

Closing Word-to-LaTeX window

Did you know that you can close Word-to-LaTeX just by pressing Esc key.

Every single Microsoft Word document is different. Different documents use different font sizes, some documents use hard-coded tabs for indenting, some authors do it more clever using styles, somebody uses built-in styles for headings, somebody not, etc. The huge variety of Word documents is the reason why it is good to consider changing the default Word-to-LaTeX configuration for each document you convert. Often only a few small changes may produce a much better (and usually cleaner) output file.

Various options can be set on all tabs following the Conversion tab. They all will be described in more detail later. Here are a few notes and tips regarding the Word-to-LaTeX configurations.

If you need to save the configuration for future use (e.g., for a document of a same kind you will convert later), click Configuration → Save as... in the main menu which will save the current configuration in a XML file. To load the previously saved configuration select Configuration → Load... from the main menu and select the configuration file.

If you want to reset the configuration to a default state, click Configuration → Preset in the main menu and select one of the options.

3.3 Command-line Converter

When you need to convert tons of files using Word-to-LaTeX, the command-line converter will help you a lot as it works with the same configuration files as the graphical converter. Therefore, you will usually prepare and tweak the configuration using the graphical interface, save it to a file, and let the command-line converter work. It is very easy to call Word-to-LaTeX from a batch script or any other program or system (e.g., a CMS system).

You will find word-to-latex.exe executable in the Word-to-LaTeX folder (usually c:\Program Files\Word-to-LaTeX). It can be executed like this:

word-to-latex.exe -i inputFile [-o outputFile] [-opt confFile]

The only required option is -i. When the output file is omitted, the input file name appended with .tex extension is used as the output file. If the configuration file is not specified, <path>\config\latex-config.xml will be used (where <path> is the folder where word-to-latex.exe is located). The command-line converter will produce the same progress information you know from the graphical converter.

Option Description
-i path to the input file
-o path to the output file
-opt path to the configuration file

4. Purchasing

4.1 Evaluating

Before you purchase a Word-to-LaTeX license key, you can evaluate it for 14 days. This allows you to make sure that Word-to-LaTeX fits your needs. If you have any kind of comment during the evaluation period, or you have a problem with installing the converter or converting some document, please let us know to . We are always open to suggestions and are happy to implement additional features users would like to see in Word-to-LaTeX.

The evaluation version has only a few limitations which, of course, disappear after you purchase a license key.

4.2 Obtaining License Key

Please follow these steps to obtain a license key. It is a question of 5 minutes to make a full version from your evaluation version.

  1. Go to Word-to-LaTeX register page and select the number of licenses. You will redirected to a secure payment gateway.
  2. After you have paid, you will receive your license key in a few minutes by email.
  3. When you have the license key, open Word-to-LaTeX and select Help → About from the main menu
  4. Enter the license key and press Register

Register Word-to-LaTeX

5. Troubleshooting & FAQ

You will find the list of most common problems that sometimes happen with Word-to-LaTeX. If none of these suggestions helps you, please let us know and we will glad to help you.

5.1 Repair Microsoft Word

Microsoft Word sometimes gets corrupted (the corruption itself has nothing in common with the Word-to-LaTeX installation) which causes various MS Word add-ins and templates, including Word-to-LaTeX, to stop working. The corruption of MS Word usually causes one of the following messages to appear.

To repair MS Word and make Word-to-LaTeX work, do the following steps. Please keep in mind that "repair" is not the same as "reinstall". Your MS Word installation will stay unaffected and nothing will be lost.

  1. Go to the Windows Control Panel and select Add/Remove Programs.
  2. Find Microsoft Office item in the list and click the Change button.
  3. Select Repair and proceed

5.2 Install Microsoft Windows/Office Updates

Be sure you have all Windows, Office, and .NET framework updates installed. Especially make sure you have the latest Windows Service Pack and Office Service Pack installed.

5.3 Microsoft Office 64-bit

The default Word-to-LaTeX installation works with both 32-bit and 64-bit versions of Windows. But, if you have Microsoft Office 64-bit (which is not very common) you will have install Word-to-LaTeX 64-bit (Word-to-LaTeX 32-bit will not work with MS Office 64-bit).